Scheduled for July 04, 2025 at 12:00 PM – July 05, 2025 at 1:48 AM
Affects
commonlit.org
Under maintenance from 12:00 PM to 1:48 AM
Completed
July 05, 2025 at 1:48 AMCompleted
July 05, 2025 at 1:48 AMMaintenance has completed successfully.
Update
July 04, 2025 at 8:51 PMIn progress
July 04, 2025 at 8:51 PMMaintenance is now in progress.
In progress
July 04, 2025 at 12:00 PMIn progress
July 04, 2025 at 12:00 PMMaintenance is now in progress
Update
July 04, 2025 at 12:00 PMPlanned
July 04, 2025 at 12:00 PMOn Friday, July 4th, we will be performing planned upgrades to our infrastructure. During this time, CommonLit will be unavailable for use. We will provide updates as the upgrades proceed.
Planned
July 04, 2025 at 12:00 PMPlanned
July 04, 2025 at 12:00 PMMaintenance didn't start yet.