Scheduled for July 25, 2026 at 1:00 AM – 2:08 AMUTC
Affects
commonlit.org
Under maintenance from 1:00 AM to 2:08 AM
Updates
Completed
July 25, 2026 at 2:08 AMUTC
Completed
July 25, 2026 at 2:08 AMUTC
Maintenance has completed successfully.
In progress
July 25, 2026 at 1:00 AMUTC
In progress
July 25, 2026 at 1:00 AMUTC
Maintenance is now in progress
Planned
July 23, 2026 at 3:31 PMUTC
Planned
July 23, 2026 at 3:31 PMUTC
We will be performing maintenance on our infrastructure the evening of Friday, July 24th. During this time, commonlit.org may be unavailable for use. We'll provide ongoing updates during the maintenance as we progress.