CommonLit - CommonLit is slow to load – Incident details
Get updates
Email
Slack
Microsoft Teams
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
CommonLit is slow to load
Resolved
Degraded performance
Started 19 days ago
September 01, 2026
Lasted about 4 hours
September 01, 2026
6:16
9:46 PM
UTC
Affected
commonlit.org
Degraded performance from 6:16 PM to 9:46 PM
Updates
Resolved
September 01, 2026 at 9:46 PM
UTC
Resolved
September 01, 2026 at 9:46 PM
UTC
This incident has been resolved.
Investigating
September 01, 2026 at 6:16 PM
UTC
Investigating
September 01, 2026 at 6:16 PM
UTC
We are currently investigating this incident.
UTC
UTC
UTC
UTC
UTC