CommonLit - Issues with Cloudflare DNS – Incident details

All systems operational

Issues with Cloudflare DNS

Resolved
Major outage
Started 19 days agoLasted about 4 hours

Affected

Infrastructure

Cloudflare DNS

Updates
  • Resolved
    Resolved

    Cloudflare is restoring service to their global network.

  • Monitoring
    Monitoring

    Cloudflare is experiencing a global network incident. During this time, some users will be unable to reach commonlit.org. We are continuing to monitor and will update as the situation evolves.