CommonLit - Degraded Service – Incident details

All systems operational

Degraded Service

Resolved
Major outage
Started 23 days agoLasted 37 minutes

Affected

commonlit.org

Major outage from 11:30 AM to 12:07 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are aware of the issue and have identified the cause. Service will be restored very shortly.